A Beginner's Guide: How to Patch AppleHDA for Laptops


EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
515
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hi i have laptop Acer 4752 with audio alc269 i try this patch but not success any help?
Incomplete PR files attached.
 

Corbe

New member
Joined
Oct 1, 2019
Messages
4
Motherboard
Acer 4752 hm65
CPU
i5 2430m
Graphics
intel hd3000
OS X/macOS
10.14.6
Bootloader
Clover (Legacy)
Mobile Phone
Android
What is that PR files mate i am beginner of this :D
 

Corbe

New member
Joined
Oct 1, 2019
Messages
4
Motherboard
Acer 4752 hm65
CPU
i5 2430m
Graphics
intel hd3000
OS X/macOS
10.14.6
Bootloader
Clover (Legacy)
Mobile Phone
Android
Well complete model is Acer 4752,
cpu - i5 2430m
wifi - ath9285
audio ALC269VB
touchpad synaptics
bluetooth broadcom
and everything working fine except audio
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
515
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Well complete model is Acer 4752,
cpu - i5 2430m
wifi - ath9285
audio ALC269VB
touchpad synaptics
bluetooth broadcom
and everything working fine except audio
Please attach your complete Problem Reporting files.
 

Corbe

New member
Joined
Oct 1, 2019
Messages
4
Motherboard
Acer 4752 hm65
CPU
i5 2430m
Graphics
intel hd3000
OS X/macOS
10.14.6
Bootloader
Clover (Legacy)
Mobile Phone
Android
Here it is audio alc269vb not working, lan is broadcom and not working too, brightness manager not showing up and i got screen glitches on vga hd3000
 

Attachments

Last edited:

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
515
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
and everything working fine except audio
This is why we ask for PR files.
Here it is audio alc269vb not working, lan is broadcom and not working too, brightness manager not showing up and i got screen glitches on vga hd3000
No kextcache output attached. The EFI is not upto the mark.
Delete the kexts from L/E and S/L/E.
Follow the guide here: https://www.elitemacx86.com/threads/guide-how-to-boot-macos-installer-on-laptops-using-clover-uefi-legacy.177/
Once you've got it installed, patch your DSDT according to this guide: https://www.elitemacx86.com/threads/guide-how-to-patch-laptop-dsdt-and-ssdts.178/
Once you've patched your ACPI, fix your Intel HD Graphics 3000 according to this guide: https://www.elitemacx86.com/threads/fix-intel-hd-graphics-3000-on-macos-mojave-10-14-x.332/
Once you follow it to till the 4th step, follow the rest from here: https://www.elitemacx86.com/threads/fix-intel-hd-graphics-3000-on-macos-mojave-10-14-x.332/page-4#post-1080
Then, it comes to the Audio. According to your Codec, use AppleALC.

Reply with new files.
 

Fancy2M

New member
Joined
Oct 16, 2019
Messages
1
Motherboard
Lenovo Ideapad Y580 (1920*1080)
CPU
Intel Core i7-3610QM
Graphics
Intel HD 4000
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mobile Phone
iOS
Hello there, I just registered to this forum because this guide didn't work for me.
I followed the guide step by step and even doublechecked everything, but I just can't get my Audio to work.
I'm running macOS Mojave 10.14.6 and my Audio Codec is ALC269VC. I tried all three versions in the patcher, but none worked.
The problem reporting files are attached, I hope anyone of you can help me to fix my problem.

Thanks in advance!
 

Attachments

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
515
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hello there, I just registered to this forum because this guide didn't work for me.
I followed the guide step by step and even doublechecked everything, but I just can't get my Audio to work.
I'm running macOS Mojave 10.14.6 and my Audio Codec is ALC269VC. I tried all three versions in the patcher, but none worked.
The problem reporting files are attached, I hope anyone of you can help me to fix my problem.

Thanks in advance!
Incomplete PR files attached. Kextcache output is missing.
The files are not upto the mark. I suggest you to start from here: https://www.elitemacx86.com/threads/guide-how-to-boot-macos-installer-on-laptops-using-clover-uefi-legacy.177/

Attach the new PR files.