apfs booting problem on LG Gram 17

rdmitry0911

New member
Joined
Apr 10, 2020
Motherboard
LG Gram 17z990
CPU
i7-8565U
Graphics
UHD620 Whiskey Lake
OS X/macOS
10.14.x
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android
Hi guys, I have LG 17 Gram 17z990 i7-8565u uhd620 whiskey lake, 16GB ram, 1TB intel nvme, clover 5112 and macos 10.14.5. and 10.15.3 Everything works just fine, but apfs booting. It stuck on ++++++++++++++++++
(see here)

The same apfs disk on another host is booting fine.
My PR:

macos-LG17-2:~ bob$ sudo kextcache -i /
KernelCache ID: 3DE2E40625E2FE8C3D59AAA1180CE962
Kext with invalid signatured (-67050) allowed: <OSKext 0x7ff334b0c9f0 [0x7fffa60698e0]> { URL = "file:///Library/Extensions/Sinetek-rtsx.kext/", ID = "com.sinet3k.Sinetek-rtsx" }

Clover zip file even without most heavy kext is 3.4 MB It is too big to be uploaded here, but I posted a link to the whole folder

Bios pictures are attached as well as ioreg, clover preboot log and bootlog

Ny help would be very much appreciated
 

Attachments

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.15.x
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hi guys, I have LG 17 Gram 17z990 i7-8565u uhd620 whiskey lake, 16GB ram, 1TB intel nvme, clover 5112 and macos 10.14.5. and 10.15.3 Everything works just fine, but apfs booting. It stuck on ++++++++++++++++++
(see here)

The same apfs disk on another host is booting fine.
My PR:

macos-LG17-2:~ bob$ sudo kextcache -i /
KernelCache ID: 3DE2E40625E2FE8C3D59AAA1180CE962
Kext with invalid signatured (-67050) allowed: <OSKext 0x7ff334b0c9f0 [0x7fffa60698e0]> { URL = "file:///Library/Extensions/Sinetek-rtsx.kext/", ID = "com.sinet3k.Sinetek-rtsx" }

Clover zip file even without most heavy kext is 3.4 MB It is too big to be uploaded here, but I posted a link to the whole folder

Bios pictures are attached as well as ioreg, clover preboot log and bootlog

Ny help would be very much appreciated
The configuration is not upto the mark and still has not been fixed. If you have made the changes, provide link to the new EFI.
If you need to start, start here:
 

rdmitry0911

New member
Joined
Apr 10, 2020
Motherboard
LG Gram 17z990
CPU
i7-8565U
Graphics
UHD620 Whiskey Lake
OS X/macOS
10.14.x
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android
The configuration is not upto the mark and still has not been fixed. If you have made the changes, provide link to the new EFI.
If you need to start, start here:
I made a new link to efi folder. Inside in log directory I put latest logs and ioreg. I'm using ocquirks instead of aptiomemoryfx as it is much more tunable. And also I did managed to boot from apfs using opencore. I converted my clover config to opencore and it works. The only problem is that every other boot it stuck on still waiting for root device. But nevertheless it is a step forward.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.15.x
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
I made a new link to efi folder. Inside in log directory I put latest logs and ioreg. I'm using ocquirks instead of aptiomemoryfx as it is much more tunable. And also I did managed to boot from apfs using opencore. I converted my clover config to opencore and it works. The only problem is that every other boot it stuck on still waiting for root device. But nevertheless it is a step forward.
Here are few issues.
The DSDT is not patched as per the guide.
The config.plist is not as per the guide. Use "config_HD615_620_630_640_650.plist"
Still the drivers directory is not upto the mark. Remove the following drivers.
  • AppleUiSupport.efi
  • AptioInputFix.efi
  • NvmExpressDxe.efi
I suggest you to remove the OcQuirks.efi, OpenRuntime.efi and rollback to AptioMemoryFix-64.efi. Make sure you remove the related .plist from the directory.
Remove NVMeFix.kext

Attach a kextcache output.
 

rdmitry0911

New member
Joined
Apr 10, 2020
Motherboard
LG Gram 17z990
CPU
i7-8565U
Graphics
UHD620 Whiskey Lake
OS X/macOS
10.14.x
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android
Here are few issues.
The DSDT is not patched as per the guide.
The config.plist is not as per the guide. Use "config_HD615_620_630_640_650.plist"
Still the drivers directory is not upto the mark. Remove the following drivers.
  • AppleUiSupport.efi
  • AptioInputFix.efi
  • NvmExpressDxe.efi
I suggest you to remove the OcQuirks.efi, OpenRuntime.efi and rollback to AptioMemoryFix-64.efi. Make sure you remove the related .plist from the directory.
Remove NVMeFix.kext

Attach a kextcache output.
Ok, I'll repatch DSDT, replace drivers and post here the results.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.15.x
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Ok, I'll repatch DSDT, replace drivers and post here the results.
First consider the booting of the Laptop and then the next step should be patching ACPI.