[Fix] Black Screen issue with MacPro 6,1 and iMac 15/17 System Definition (NVIDIA/AMD)

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.15.x
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
If you're using MacPro 6,1 or iMac 15/17 as a system definition, then you might have a black screen as macOS finishes loading. This is because the MacPro 6,1 and iMac 15/17 performs a special function on their specific OEM GPUs and displays. For non-Apple hardware this will cause a black screen.

There maybe another issue and you might start to use this fix. But before that, you should verify that this is the only issue not others. So here's a way to determine if the system is running/functional.

  1. Check if the system fan is running. The CPU fan.
  2. Check if the power LEDs are blinking.
  3. If you're having a optical drive installed, eject the drive and check
  4. Boot using nv_disable=1 and then check

After confirming, you can go ahead and fix this issue.

Here's an easy Clover patch-on-the-fly fix for it (credit to Pike R. Alpha). And you can use Clover Configurator for a user-friendly way of adding it into Kernel and kext Patches section
Code:
Name: com.apple.driver.AppleGraphicsDevicePolicy
Find* [HEX]: BA050000 00
Replace* [HEX]: BA000000 00
Comment: Prevent AGDP from loading
Here's what it should like once added.
Screen Shot 2018-09-19 at 13.17.12.png

Alternatively, you can also use Lilu & WhateverGreen kexts to achieve the same effect. You might need to make sure they're always up to date, thought, just in case.
 

stp

New member
Joined
Apr 29, 2020
Motherboard
Asus H110m-CS
CPU
Intel Core I3 7100
Graphics
Intel HD Graphics 630
OS X/macOS
11.0 (Beta)
Bootloader
Clover (UEFI)
Mac
MacBook Air
Mobile Phone
Android
Hello ! I have blank screen problem after boot. everything else is working but not getting display output. my motherboard has only VGA port for display output .Is there any fix for this ? this happened after applying fix for intel HD graphics 630 . if i remove that patch it boots with display but no GFX acceleration. i have attached config file. my motherboard has only VGA port for display output.
 

Attachments

Last edited:

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.15.x
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hello ! I have blank screen problem after boot. everything else is working but not getting display output. my motherboard has only VGA port for display output .Is there any fix for this ? this happened after applying fix for intel HD graphics 630 . if i remove that patch it boots with display but no GFX acceleration. i have attached config file. my motherboard has only VGA port for display output.
This is only valid for NVIDIA and AMD.
 

yuanyasmine

New member
Joined
May 14, 2020
Motherboard
820-00165-A 2017
CPU
Intel Core i7
Graphics
Intel HD Graphics 6000 1536 MB
OS X/macOS
11.0 (Beta)
Bootloader
OpenCore
Mac
MacBook Air
Mobile Phone
Android
Hello ! I have blank screen problem after boot. everything else is working but not getting display output. my motherboard has only VGA port for display output .Is there any fix for this ? this happened after applying fix for intel HD graphics 630 . if i remove that patch it boots with display but no GFX acceleration. i have attached config file. my motherboard has only VGA port for display output.
I have been a mac user for ten years and have encountered this problem several times. Initially, you should follow these steps when your Mac does not start the guide:

https://iboysoft.com/mac-data-recovery/mac-wont-boot-what-to-do.html

Please describe the result of the following steps:

1. can you boot into recovery mode from partition or internet recovery?

2. can you boot in safe mode?

3. can you start in Safe Verbose mode - it starts to load then ends in a blank gray screen.

4. Start in single user mode if you can, then run fsck -fy. Do you have an error message? during the restart, are there any error messages?

if you say yes, you may be able to repair your Mac. if you answer no and you can only load then find yourself in a blank gray screen, there is a problem with the hardware, the motherboard maybe. in this situation, please ask for help from Apple Support.

5. reset NVRAM and SMC. does that make any changes?