[Fix] Intel HD Graphics 3000 on macOS Mojave 10.14.x


EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
481
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Sorry, i am new at this platform so what is it meaning PR files. I am using intel power gadget Gfx looks like constant 0.65ghz
PR means Problem Reporting files.
 

mykomicrec

New member
Joined
Aug 25, 2019
Messages
4
Motherboard
Asus K53SV
CPU
i5-2410m
Graphics
Nvidia Gt540m
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
iMac Pro
Mobile Phone
iOS
PR means Problem Reporting files.
I hope I did it properly also my system isn't stable, freezing in a few hours after system boot.I thought reason of video card problems
 

Attachments

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
481
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
I hope I did it properly also my system isn't stable, freezing in a few hours after system boot.I thought reason of video card problems
Several things are not upto the mark.
The ACPI is not patched. Follow the guide here: https://www.elitemacx86.com/threads/guide-how-to-patch-laptop-dsdt-and-ssdts.178/

The config.plist is not as per the guide. Follow the guide here: https://www.elitemacx86.com/threads/guide-how-to-boot-macos-installer-on-laptops-using-clover-uefi-legacy.177/

The config.plist is having an invalid Fake ID. It will result in non-working of Graphics.

Still old method is being used to fix the Brightness. Follow the guide here: https://www.elitemacx86.com/threads/guide-how-to-enable-backlight-control-on-laptop.182/
 

mykomicrec

New member
Joined
Aug 25, 2019
Messages
4
Motherboard
Asus K53SV
CPU
i5-2410m
Graphics
Nvidia Gt540m
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
iMac Pro
Mobile Phone
iOS
Several things are not upto the mark.
The ACPI is not patched. Follow the guide here: https://www.elitemacx86.com/threads/guide-how-to-patch-laptop-dsdt-and-ssdts.178/

The config.plist is not as per the guide. Follow the guide here: https://www.elitemacx86.com/threads/guide-how-to-boot-macos-installer-on-laptops-using-clover-uefi-legacy.177/

The config.plist is having an invalid Fake ID. It will result in non-working of Graphics.

Still old method is being used to fix the Brightness. Follow the guide here: https://www.elitemacx86.com/threads/guide-how-to-enable-backlight-control-on-laptop.182/
Thank you so much I appreciate that my system is stable finally.. but intel hd 3000 ghz still same as before. I got "Error loading kernel cache (0x9)" when I load Rehabman's config that's why I am using my config similar to Rehabman's so should I do another fix or patch?
 

Attachments

RagnarL

New member
Joined
Sep 11, 2019
Messages
1
Motherboard
T430
CPU
i5-3350
Graphics
Intel HD Graphics 4000
OS X/macOS
10.13.6
Bootloader
Clover (UEFI)
Mobile Phone
Android
Dear,

to first thank you for your help

I want to install on a Packard Bell Laptop Mojave
It have a second gen i3-2250M CPU
6GB RAM
Intel HD Graphics 3000

The Laptop boot to the installer and system without problems but every time after I installed the HD Graphics 3000 driver the monitor turns black when I boot the system. If I dont install the driver the monitor show up and everything seems to be fine but the VRAM is only 5MB

I tried many different solutions but nothing helped

The DSDT is patched with a HD Graphics 3000 high resolution and with a GF0 to iGPU rename patch

Attachment:
IOReg Log
DPCI Screenshots
Clover Folder
HD Graphics 3000 driver that I used
 

Attachments

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
481
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Dear,

to first thank you for your help

I want to install on a Packard Bell Laptop Mojave
It have a second gen i3-2250M CPU
6GB RAM
Intel HD Graphics 3000

The Laptop boot to the installer and system without problems but every time after I installed the HD Graphics 3000 driver the monitor turns black when I boot the system. If I dont install the driver the monitor show up and everything seems to be fine but the VRAM is only 5MB

I tried many different solutions but nothing helped

The DSDT is patched with a HD Graphics 3000 high resolution and with a GF0 to iGPU rename patch

Attachment:
IOReg Log
DPCI Screenshots
Clover Folder
HD Graphics 3000 driver that I used
No kextcache output attached.
The ACPI is not patched properly. It must be saved as .aml extension to read. Follow the guide here: https://www.elitemacx86.com/threads/guide-how-to-patch-laptop-dsdt-and-ssdts.178/
NullCPUPowerManagement must be removed.
Update WEG+Lilu and the other kexts.
Remove the kexts related to HD 3000. Install the package with the appropriate selection. Rebuild the cache. Restart and reply with new files. If possible, provide the screenshots for the package you install.
 

dkla

New member
Joined
Oct 5, 2019
Messages
1
Motherboard
Gigabyte
CPU
i7-2600K
Graphics
HD3000
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mobile Phone
iOS
WARNING! The last step only works for Mojave 10.14.(0, 1, 2, 3). If you are upgrading from 10.14.(0, 1, 2, 3) to higher version, first delete all of the files for HD3000(the ones provided in the zip on the first page of this thread) located `System/Library/Extensions` then upgrade or you will end up with a black screen after boot. Here is a easy to install standalone package with fixes for each version of Mojave. On the `Installation type` selection, make sure you select only one of the provided 3 choices that is meant for your Mojave version.

Before applying this patch make sure you follow the steps from 1 to 4.
OMG thanks so much for this installer package!! Upgrading from 10.4.4 to 10.4.6 gave me the black screen, but your installer package did the trick quite nicely.

I'm not on a laptop (an older Gigabyte mobo with HD3000 graphics) but this solution still worked, so thanks again!!! :)
 
  • Like
Reactions: EliteMacx86

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
481
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
OMG thanks so much for this installer package!! Upgrading from 10.4.4 to 10.4.6 gave me the black screen, but your installer package did the trick quite nicely.

I'm not on a laptop (an older Gigabyte mobo with HD3000 graphics) but this solution still worked, so thanks again!!! :)
Nice!