[Fix] Intel HD Graphics 4200/4400/4600 on macOS 10.12.x and Later


EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
540
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
macOS supports a wide range of Intel HD Graphics (also referred to as iGPU) but some of them might not work out of the box.
This guide will enable Full QE/CI on your Hackintosh.
This fix is for the Hackintosh users who are using Intel HD Graphics as the main GPU.

Before you start with this guide, please know something about the performance. Graphics enhance the performance and helps to work smoothly. In macOS, full acceleration requires that both Quartz Extreme and Core Image (QE/CI) should work together.

Quartz Extreme and Core Image (QE/CI) should work together to enable full acceleration on macOS’s GUI. It utilizes the complete Graphics capabilities. In case if you haven’t enabled QE/CI on your graphic card, you won’t be able to use your macOS smoothly and there would be lots of lags and artifacts, graphic related issues and poor refresh rate. Also the dock would not be transparent. Therefore it is very important to ensure that your graphic is working with full QE/CI.

Requirements:
  • Intel HD Graphics 4200, 4400 and 4600
  • Original Graphics kexts in S/L/E
  • macOS Sierra 10.12.0 or later

Step 1
BIOS Setting:

The very first step is to setup your BIOS. This guide will only include settings for Intel HD users.
To access your BIOS/UEFI, press and hold Delete key on your Keyboard. The key maybe different in your case. Refer to your laptop Guide/Manual.
The BIOS in laptops has very less options. If the option is available for Graphics, set DVMT to 64MB
Save & Exit Setup.

Step 2
Mount EFI Partition:

  1. Mount EFI Partition of your system drive.
Step 3
Edit your config.plist file:

  1. The next step is to edit your config.plist file and make necessary edits.
  2. Navigate to EFI\Clover and open your config.plist with Clover Configurator.
  3. Navigate to Acpi tab and add the following patch in DSDT section of your config.plist.
Code:
Comment: change GFX0 to IGPU
Find* [HEX]: 47465830
Replace [HEX]: 49475055

4. Navigate to Boot tab and check the following :​
  • Check nv_disable=1 box
5. Navigate to Devices section and then Fake ID section.​
6. Under Intel GFX column, select the existing values and delete it, if any.​
7. Under Intel GFX column, type 0x04128086

8. Navigate to Graphics tab and add the following:​

  • Check Inject Intel box
  • ig-platform-id: 0x0a260006
9. Save your config.plist file.​

Step 4: Download the Graphics kexts
The next step is to download the required kexts to enable graphics. FakePCIID doesn't works alone. FakePCIID and FakePCIID_Intel_HD_Graphics.kext is needed together to work with conjunction in order to enable the graphics.

Downloads
  1. FakePCIID
Notes :
  • Download the latest version only.
Step 5: Installing Graphics kexts

After editing your config.plist file, the next step is to install the Graphics kexts.
You can use either terminal or any other app for installing the kexts.

Download the kexts
Extract it to your Desktop
Open terminal
Type
Code:
sudo cp -R /Users/your user name/Desktop/FakePCIID_Intel_HD_Graphics.kext FakePCIID
Press enter, when promoted, enter your password

Note :
  • Make sure to replace your user name with "your user name"

Restart your System
  1. After performing all the above steps, restart your system in order to enable the Intel HD Graphics.
  2. Now you should be able to get your Intel HD Graphics 1536 MB will full QE/CI. And your Dock would be also transparent.

Problem Reporting

Details :
  1. Intel UHD Graphics model
  2. macOS version
  3. Copy of IOReg
Screen shots :
  • DPCIManager/Status
  • About This Mac
  • System Information/Graphics/Displays
Clover Files :
  • Compress EFI/Clover, exclude the themes folder. Do not include complete EFI folder.
Put all files in a folder with your name, compress files as Zip and attach files using site attachments only. Do not use any external links.

Credits :
RehabMan
 

rBoLt168

New member
Joined
Feb 8, 2019
Messages
14
Motherboard
Folio 9470m
CPU
i7
Graphics
Intel HD4000
OS X/macOS
10.14.4
Bootloader
Clover (UEFI)
Mac
MacBook Air
Mobile Phone
Android, iOS
Hello,
Thank you for your guide, unfortunately it didn't work for me. I am still getting 7mb of Vram only.
I am attaching the Problem Reporting as required. Looking forward to hear from you. thank you in advance.
 

Attachments

Last edited by a moderator:

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
540
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS

rBoLt168

New member
Joined
Feb 8, 2019
Messages
14
Motherboard
Folio 9470m
CPU
i7
Graphics
Intel HD4000
OS X/macOS
10.14.4
Bootloader
Clover (UEFI)
Mac
MacBook Air
Mobile Phone
Android, iOS
Please fix your profile as per FAQ. https://www.elitemacx86.com/threads/faq-read-first-questions-related-to-laptop.175/
The files are not as per the guide. Next to that, the ig-platform-id you're using is not correct. The guide says to use 0x0a260006 as a platform id and you're injecting 0x0d220003 which is wrong.
Hello @EliteMacx86 appreciate you promptly coming back to me. the reason it was one 0x0d220003 because I was playing around with the graphics settings when I took the Problem report. Regarding the profile I am making multiple machines now so it was not consistent with the current machine i was working on.
You are mentioning some files are you referring to the Kext installed?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
540
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hello @EliteMacx86 appreciate you promptly coming back to me. the reason it was one 0x0d220003 because I was playing around with the graphics settings when I took the Problem report. Regarding the profile I am making multiple machines now so it was not consistent with the current machine i was working on.
You are mentioning some files are you referring to the Kext installed?
Please fix your profile as per FAQ. https://www.elitemacx86.com/threads/faq-read-first-questions-related-to-laptop.175/
Follow the installation guide here: https://www.elitemacx86.com/threads/guide-how-to-boot-macos-installer-on-laptops-using-clover-uefi-legacy.177/

Report with new set of files.
 

rBoLt168

New member
Joined
Feb 8, 2019
Messages
14
Motherboard
Folio 9470m
CPU
i7
Graphics
Intel HD4000
OS X/macOS
10.14.4
Bootloader
Clover (UEFI)
Mac
MacBook Air
Mobile Phone
Android, iOS
Hello,
thanks for your inputs, I reverted back the changes as per guide. I need to removed the Intel Inject again so I can extract the information required.
Attached is the Problem Report for help please. thank you very much in advance.

  • CPU model - Intel i5-4210Y
  • Chipset - Intel (mobo E241819)
  • Graphics - Intel HD 4200 (integrated)
  • RAM - 8GB DDR3
  • Audio Codec - ALC662v2
I hope this is all you needed.
This is not a notebook, this is a DIY NUC with a mini pc case. Just using a mobile components.
 

Attachments

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
540
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hello,
thanks for your inputs, I reverted back the changes as per guide. I need to removed the Intel Inject again so I can extract the information required.
Attached is the Problem Report for help please. thank you very much in advance.

  • CPU model - Intel i5-4210Y
  • Chipset - Intel (mobo E241819)
  • Graphics - Intel HD 4200 (integrated)
  • RAM - 8GB DDR3
  • Audio Codec - ALC662v2
I hope this is all you needed.
This is not a notebook, this is a DIY NUC with a mini pc case. Just using a mobile components.
Inject Intel must be checked. Again, the files are not as per the guide. It's not the appropriate config.plist. Next to that, you've provided incomplete PR files. IOReg is missing.
You should update the specs in your profile. Not here.
 

rBoLt168

New member
Joined
Feb 8, 2019
Messages
14
Motherboard
Folio 9470m
CPU
i7
Graphics
Intel HD4000
OS X/macOS
10.14.4
Bootloader
Clover (UEFI)
Mac
MacBook Air
Mobile Phone
Android, iOS
Hi,

after Step 5 do i need to install the Kext in the clover kext folder?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
540
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hi,

after Step 5 do i need to install the Kext in the clover kext folder?
Remove the unnecessary kexts from the Clover/Kexts/Other directory. And use Lilu+WEG. The Graphics kexts are not required to install. Reply with new set of PR files.
 

rBoLt168

New member
Joined
Feb 8, 2019
Messages
14
Motherboard
Folio 9470m
CPU
i7
Graphics
Intel HD4000
OS X/macOS
10.14.4
Bootloader
Clover (UEFI)
Mac
MacBook Air
Mobile Phone
Android, iOS
Hi EliteMac appreciate your attention on this, thank you. I attached a new set of PR files. I have been formatting this machine for the 4-5 times already. Just to mention again that I unchecked the Intelinject so I can boot up the machine, else I till have the "kext Stall 'IGPU' " and won't be able to take the screenshots.

Intel UHD Graphics: HD4200
OSX: 10.13.6

thank you in advance.
 

Attachments