[Fix] Intel HD Graphics 4200/4400/4600 on macOS 10.12.x and Later


rBoLt168

New member
Joined
Feb 8, 2019
Messages
14
Motherboard
Folio 9470m
CPU
i7
Graphics
Intel HD4000
OS X/macOS
10.14.4
Bootloader
Clover (UEFI)
Mac
MacBook Air
Mobile Phone
Android, iOS
Hi EliteMac appreciate your attention on this, thank you. I attached a new set of PR files. I have been formatting this machine for the 4-5 times already. Just to mention again that I unchecked the Intelinject so I can boot up the machine, else I till have the "kext Stall 'IGPU' " and won't be able to take the screenshots.

Intel UHD Graphics: HD4200
OSX: 10.13.6

thank you in advance.

Just a quick update, my audio is working now.
So I am left with this video graphics limitation.
 
  • Like
Reactions: EliteMacx86

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
540
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hi EliteMac appreciate your attention on this, thank you. I attached a new set of PR files. I have been formatting this machine for the 4-5 times already. Just to mention again that I unchecked the Intelinject so I can boot up the machine, else I till have the "kext Stall 'IGPU' " and won't be able to take the screenshots.

Intel UHD Graphics: HD4200
OSX: 10.13.6

thank you in advance.
Use the config.plist from here: https://www.elitemacx86.com/threads/guide-creating-a-basic-config-plist-file-for-booting-macos.257/
Make sure you change the SMBIOS to iMac 14,2
Remove FakePCIID.kext and FakePCIID_Intel_HDMI_Audio.kext from Clover/Kexts/Other
Change the ig-platform-id to 0x0d220003 and also check Inject Intel checkbox.

Reply with new set of files.
 

rBoLt168

New member
Joined
Feb 8, 2019
Messages
14
Motherboard
Folio 9470m
CPU
i7
Graphics
Intel HD4000
OS X/macOS
10.14.4
Bootloader
Clover (UEFI)
Mac
MacBook Air
Mobile Phone
Android, iOS
Hi Elitemac, Thank you for coming back to me. I tried those you suggested without any luck.
I also have to uncheck the Inject to boot-up.
new PR attached please the verbose screenshot.

thank you for your support.
 

Attachments

Last edited:

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
540
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hi Elitemac, Thank you for coming back to me. I tried those you suggested without any luck.
I also have to uncheck the Inject to boot-up.
new PR attached please the verbose screenshot.

thank you for your support.
Intel GFX is empty. Use 0x04128086
Update Lilu.kext
 

rBoLt168

New member
Joined
Feb 8, 2019
Messages
14
Motherboard
Folio 9470m
CPU
i7
Graphics
Intel HD4000
OS X/macOS
10.14.4
Bootloader
Clover (UEFI)
Mac
MacBook Air
Mobile Phone
Android, iOS
Thank you EliteMac, now I can boot with Inject ticked. Unfortunately the VRAM is still 7MB. Attached updated PR files.
 

Attachments

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
540
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Thank you EliteMac, now I can boot with Inject ticked. Unfortunately the VRAM is still 7MB. Attached updated PR files.
Set DVMT Pre-Allocated to 64MB
The IGFX should be "0x04128086" not 0x04218086
Attach a kextcache output. Type "sudo kextcache -i/" in terminal.

Reply with new set of PR files.
 

rBoLt168

New member
Joined
Feb 8, 2019
Messages
14
Motherboard
Folio 9470m
CPU
i7
Graphics
Intel HD4000
OS X/macOS
10.14.4
Bootloader
Clover (UEFI)
Mac
MacBook Air
Mobile Phone
Android, iOS
Hello mate,

DVMT adjusted and IGFX also fixed.
Back to the same problem were I can't boot without unchecking the Inject.
 

Attachments

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
540
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hello mate,

DVMT adjusted and IGFX also fixed.
Back to the same problem were I can't boot without unchecking the Inject.
The Acpi patch "Change GFX0 to IGPU" is missing from the config.plist. The ig-platform-id has been also changed. Use 0x0d220003 as a platform id.
Remove the following kexts from S/L/E
Lilu.kext
AppleALC.kext
WhateverGreen.kext

Remove the following kexts from L/E
Lilu.kext
WhateverGreen.kext
FakeSMC.kex

Reply with new set of files
 

rBoLt168

New member
Joined
Feb 8, 2019
Messages
14
Motherboard
Folio 9470m
CPU
i7
Graphics
Intel HD4000
OS X/macOS
10.14.4
Bootloader
Clover (UEFI)
Mac
MacBook Air
Mobile Phone
Android, iOS
Hello EliteMac,

thank you for your feedback and tips.
all advices are performed but still cannot boot with Inject.

thanks for your support.
 

Attachments

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Messages
540
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hello EliteMac,

thank you for your feedback and tips.
all advices are performed but still cannot boot with Inject.

thanks for your support.
Install FakePCIID.kext and FakePCIID_Intel_HD_Graphics.kext to S/L/E
Reboot and you should be good to go.
Reply with new sets of files.