[Fix] Intel HD Graphics 520 and 620 on macOS 10.14.4



ciestavira

New member
It is my first contribution to the forum. Finally, after many tests and search forums, I managed to run the Intel HD Graphics 520 and 620 graphics card in my Hackintosh, a Vorke V2 barebone with an Intel Skylate i7-6500U. I hope you find my contribution useful.

1 - In Acpi -> Patches

change GFX0 to IGPU

2 - In Boot -> Arguments

Delete if it was activated: -disablegfxfirmware

3 - In Devices -> Fake ID

Delete content if it contained something: IntelGFX

4 - In Devices -> Properties -> Devices*

PciRoot(0x0)/Pci(0x2,0x0) (gfxutil -f display) to find out yours

5 - In Devices -> Properties

Intel HD Graphics 520 / Intel HD Graphics 620

AAPL,ig-platform-id 00001619 (19160000) DATA / 00001659 (59160000) DATA

framebuffer-fbmem 00005400 (21 MB) DATA / 00000000 (0 MB) DATA

framebuffer-patch-enable 01000000 (1) DATA / 01000000 (1) DATA

framebuffer-stolenmem 00008800 (34 MB) DATA / 00008800 (34 MB) DATA

framebuffer-unifiedmem 00000060 (1536 MB) DATA / 00000060 (1536 MB) DATA

Do not put what is in parentheses.

6 - In Graphics -> Remove if it was selected

- Inject Intel
- ig-platform-id


Sorry for my English. I am Spanish and I used the Google translator.
 
Done it, but there was a problem. After booting, the screen was black with backlight, and I was sure the system work, just show nothing.
Laptop is surface pro 2017 , i5, 8G, 256G,HD620.
 

herno96

New member
Sorry i didnt undestand point 5. How should it be?

AAPL,ig-platform-id 00001619 (19160000) DATA
AAPL,ig-platform-id 00001659 (59160000) DATA

Like this?

[EDIT]

Gotcha! My bad!

Intel HD Graphics 520 = AAPL,ig-platform-id 00001619 (19160000) DATA
Intel HD Graphics 620 = AAPL,ig-platform-id 00001659 (59160000) DATA

I see the improvement, but google chrome still having just a little lag, not like safari that works very well.

Thanks!
 
Last edited:

Similar threads



Top