[Guide] Gigabyte Z390 I AORUS PRO WiFi - Intel Core i5 9600K - Intel UHD Graphics 630

Striker

New member
Joined
Oct 20, 2018
Motherboard
Gigabyte B360 Gaming 3 WiFi
CPU
Intel Core i5 9400F
Graphics
Sapphire Nitro plus Radeon RX580
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mobile Phone
iOS
Complete installation guide for installing macOS Mojave 10.14 (18A391) on a Custom Build PC

Specifications :

Motherboard : Gigabyte Z390 I AORUS PRO WiFi
CPU: Intel Core i5 - 9600K
RAM: 32 GB 3200MHz
IGPU: Intel UHD Graphics 630
Graphics: None
SSD: ADATA XPG SX8200 Pro
Audio: Realtek ALC 1220-VB
Display: 32" (1920x1080)

Summary :

What's works?

Audio
Graphics
Ethernet
HDMI
Power Management
iMessage
FaceTime
iCloud
USB 2.0, 3.0 Ports
Type C, Type A

Not working

Everything works

Bootable Media Creation

STEP 1

To create Bootable USB for installation

Insert USB Flash Drive and open Disk Utility

Select USB Flash Drive and Erase it with following parameters

Name : USB
Format
: OS X Extended (Journaled)
Scheme
: GUID Partition Map

Launch Terminal

Copy and paste the following sudo command in terminal

Code:
sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB
Enter Password, when it asks

Press (Y) for confirmation of the proceeding process and press Enter key

Close Terminal after execution of the process

STEP 2

Download Clover EFI Bootloader from the Forum Downloads Section

Run Clover EFI bootloader installer package

In Clover Bootloader click on Change Install Location and select installation Drive i.e Install macOS Mojave.

Click on Customize and configure the following settings.

Install Clover for UEFI booting only
Install Clover in the ESP

Themes: Select any
Drivers64UEFI: AptioMemoryFix-64 , ApsDriverLoader-64

Confirm the above options and click on Install. Enter Password when it asks.

Click on Close after execution of the process

STEP 3 :

Now you'll have to place the necessary Files, Kexts & Config.plist

Navigate to: EFI/CLOVER
Download the Config.plist file from here: https://www.elitemacx86.com/threads/guide-creating-a-basic-config-plist-file-for-booting-macos.257/
Change the SMBIOS to iMac Pro 1,1
Rest will be as it is

Navigate to: EFI/CLOVER/drivers64UEFI/
Place HFSPlus.efi : https://github.com/JrCs/CloverGrowerPro/raw/master/Files/HFSPlus/X64/HFSPlus.efi

After that
Navigate to: EFI/CLOVER/kexts/

Place following kexts in the folder
FakeSMC.kext: https://github.com/RehabMan/OS-X-FakeSMC-kozlek
VoodooPS2Controller.kext: https://github.com/RehabMan/OS-X-Voodoo-PS2-Controller
USBInjectAll.kext: https://github.com/RehabMan/OS-X-USB-Inject-All
Lilu.kext: https://github.com/acidanthera/Lilu
WhateverGreen.kext: https://github.com/acidanthera/WhateverGreen

Now, everything is done USB is fully prepared for installation

UEFI settings

Set X.M.P to Profile 1.
Set CSM Support to Disabled.
Set XHCI Hand-of to Enabled.
Set SATA Mode to AHCI.
Set VT-d Option to Disable
Set Windows 8/10 Feature to Other OS

Booting the Installer using USB

After preparing installation USB

Plug the USB flash drive in USB 2.0/3.0 port and boot to boot menu

Select USB with the UEFI prefix and press enter to boot

Use following boot args :
-v
nv_disable=1
slide=0

Select Boot macOS Install from Install macOS Mojave and press enter to boot

When at installation screen

select preferred language and continue

Select Disk Utility and continue

click on View and select Show all Devices

select Hard Drive or SSD on which you want to install macOS

Select the Drive and click on Erase button

Erase it with following parameters

Name : Macintosh HD* (You can rename it later on)
Format
: APFS
Scheme : GUID Partition Map


After execution of the process Close Disk Utility

Select Install macOS and continue with the options.

Now select Macintosh HD* and click on Install.

When the PC restarts, select Boot macOS Install from Macintosh HD or (Drive name) and press enter

After installation, boot it using USB, but this time select Macintosh HD or (Drive name) and press enter

When you're at the welcome screen, continue with the basics options such as Keyboard setup, Network, Computer Account and Privacy settings

Post Installation

Boot from System Drive

Mount the EFI Partitions of BOTH USB as well as Hard Drive/SSD

Open EFI Partition of Hard Drive

Select EFI folder and then move to Trash

Open EFI Partition of USB

Copy the EFI folder to EFI Partition of Hard Drive.

Graphics

Intel UHD Graphics 630 is supported and will run in full QE/CI OOTB

Network


The PC uses Intel I219V Ethernet Chipset. Install Realtek IntelMausiEthernet.Pkg

Audio

The PC uses a Realtek ALC 1220-VB Audio Codec

Download AppleALC.kext & Lilu.kext

Move the files to EFI/Clover/Kexts/10.14 and place both the kexts

Open config.plist

Use layout ID = 11

Check "ResetHDA"

USB Ports

All USB Ports works OOTB

Add USB port limit patch

Mount EFI Partition
Open config.plist file using Clover Configurator
Navigate to kernel and kext patches tab and add the following patch in config.plist.

Code:
Name: com.apple.iokit.IOUSBHostFamily
Find* [HEX]: 83FB0F0F 870B0400 00
Replace* [HEX]: 883FB3F0F 870B0400 00
Comment: USB 10.14.x by PMHeart
Code:
Name: com.apple.driver.usb.AppleUSBXHCI
Find* [HEX]: 4183FF0F 0F839404 0000
Replace* [HEX]: 4183FF3F 0F839404 0000
Comment: USB 10.14.x by PMHeart
Code:
Name: com.apple.iokit.IOUSBHostFamily
Find* [HEX]: 83E30FD3 E34109DF
Replace* [HEX]: 83E33FD3 E34109DF
Comment: USB 10.14.x by PMHeart
Save config.plist file

Restart PC for implementing the changes

Miscellaneous

App Store
iMessage
FaceTime

iCloud

To activate App Store iMessage FaceTime & iCloud, follow the instructions below :

Mount EFI partition

Open config.plist

Navigate to SMBIOS Tab

Generate a new SMBIOS for "iMac Pro 1,1"

Save config.plist

Restart PC

Login into App Store, iMessage, FaceTime and iCloud.


By following the above Guide, A full working macOS Mojave on Custom Build PC can be installed

Credits:
A special Thanks to @EliteMacx86 and @DSM2 for the wonderful guides which is super easy to follow.
 
Last edited:
  • Like
Reactions: Maurizio

velosaint

New member
Joined
Jan 16, 2020
Motherboard
Gigabyte Z390 Gaming SLI
CPU
I5 9600K
Graphics
intel 630
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
iMac
Mobile Phone
Android
I'm having trouble getting into mojave installation screen --- following the guide above. Verbose runs, no kp, then looks as if it's going to load installer but monitor goes into energy saver, and won't come out. USB drive shows activity after screen goes off for another few seconds, but can't get to install screen, when I press the keyboard activity light responds on drive, have 1920 dvi monitor w/->hdmi adapter connected mb hdmi tried on 4k tv same result, I've tried different bios (currently F8), I feel like it's the 630 fault somewhere but can't figure it out. I"ve disconnected HDMI cable / re-inserted, no change, unplugged monitor no change. I've tried waiting 30 minutes but only returns to Clover boot menu, ---

Built install from macbook pro running 13.6 and has mojave install in app folder. Thoughts?

Motherboard : Gigabyte Z390 I AORUS GAMING SLI
CPU: Intel Core i5 - 9600K
RAM: 16 GB 3200MHz
IGPU: Intel UHD Graphics 630
Graphics: None
SSD: Intel 660p 1tb
Bluetooth/Wifi combo card: Fenvi FV-HB1200
 
Last edited:

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
I'm having trouble getting into mojave installation screen. Verbose runs, no kp, then looks as if it's going to load installer but monitor goes into energy saver, and won't come out. USB drive shows activity after screen goes off for another few seconds, but can't get to install screen, when I press the keyboard activity light responds on drive, have 1920 dvi monitor w/->hdmi adapter connected mb hdmi tried on 4k tv same result, I've tried different bios (currently F8), I feel like it's the 630 fault somewhere but can't figure it out. I"ve disconnected HDMI cable / re-inserted, no change, unplugged monitor no change. I've tried waiting 30 minutes but only returns to Clover boot menu,
Common issue with HD/UHD Graphics. Have you tried to follow the guide?
No PR files attached.

Read here: