[Guide] HP Z620 Workstation - 2x 8-Core Intel Xeon E5-2670 - 96GB RAM - AMD Radeon RX580

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
So no good all week on the High Sierra install :( I followd the same steps but the machine turns off and reboots after the clover screen appears and I select install MacOS (it gets to Apple logo then shuts down, a few seconds later it reboots). I'm pretty convinced it;s my config.plist but can not be sure. I found an install guide for a z800 series with High Sierra and that caused kernel panics. Any ideas on what to look for wold be greatly appreciated, the guide for Mojave worked like a charm but my video card has some issues or I would call it a day with Mojave.
Provide your PR files to check.
 

PTR215

New member
Joined
Mar 10, 2020
Motherboard
HP Z620
CPU
Intel XEON E5-2609 2.4 GHz
Graphics
Nvidia GeForce GTX 970
OS X/macOS
10.14
Bootloader
Clover (UEFI)
Mac
Mac Pro
Mobile Phone
iOS
Thanks for the advice, I found a terminal command to generate a problem report. My question is, do I mount the USB installers EFI partition in terminal and run report on that? I am convinced I am doing something wrong as far as a memory fix. What is your preferred method for generating a problem report? A little perplexed why I had no issues to get at least install (minus graphics card) on mojave and high sierra is a headache? Any help or guidance is appreciated. thanks again and be safe!
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Thanks for the advice, I found a terminal command to generate a problem report. My question is, do I mount the USB installers EFI partition in terminal and run report on that? I am convinced I am doing something wrong as far as a memory fix. What is your preferred method for generating a problem report? A little perplexed why I had no issues to get at least install (minus graphics card) on mojave and high sierra is a headache? Any help or guidance is appreciated. thanks again and be safe!
Read here:

You can provide the files manually and compress them in one single .zip file. Currently our servers are upgraded, modification is required and will be done soon. Till then, you use Google Drive link to link your PR files.

Stay safe, stay healthy!
 

PTR215

New member
Joined
Mar 10, 2020
Motherboard
HP Z620
CPU
Intel XEON E5-2609 2.4 GHz
Graphics
Nvidia GeForce GTX 970
OS X/macOS
10.14
Bootloader
Clover (UEFI)
Mac
Mac Pro
Mobile Phone
iOS
Well great news, I got it to install!!! My BIOS reset it's settings and that was the issue. I dont know why but after the previous shutdowns I wasnt going back to confirm the BIOS settings were still the same. I got ethernet working now and played a youtube video. So this is what I am working on now and have left to figure out:

- Audio : DPCI Manager says nVidia (unknown)
-USB fix (1 out of 3 on front work BUT ALL 4 work on back - il take it though :)
-nVidia 970 updated webdrivers. Is there a newer web driver for my card? (looks great but on log in screen ONLY I get some lines across the screen)
-CPU power management

Back on track and almost there!!
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
- Audio : DPCI Manager says nVidia (unknown)
-USB fix (1 out of 3 on front work BUT ALL 4 work on back - il take it though :)
-nVidia 970 updated webdrivers. Is there a newer web driver for my card? (looks great but on log in screen ONLY I get some lines across the screen)
-CPU power management
Follow the guide on the first page and you'll have it fixed.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
- Audio : DPCI Manager says nVidia (unknown)
-USB fix (1 out of 3 on front work BUT ALL 4 work on back - il take it though :)
-nVidia 970 updated webdrivers. Is there a newer web driver for my card? (looks great but on log in screen ONLY I get some lines across the screen)
-CPU power management
Follow the guide on the first page and you'll have it fixed.
 

PTR215

New member
Joined
Mar 10, 2020
Motherboard
HP Z620
CPU
Intel XEON E5-2609 2.4 GHz
Graphics
Nvidia GeForce GTX 970
OS X/macOS
10.14
Bootloader
Clover (UEFI)
Mac
Mac Pro
Mobile Phone
iOS
Update 3/30/2020

I got High Sierra Installed

-nVidia Webdriver working
-ethernet working

-Audio is via nVidia HDMI - works very good through monitor BUT is there a way/option to also use the onboard codec and choose in preferences?

Still need Bluetooth
CPU Management

USB ports Still missing 2 on front and the 3.0 ones on the back (al together I have 5 working out of 11 (is there a total fix to use all?)
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
I got High Sierra Installed
Cool.
-Audio is via nVidia HDMI - works very good through monitor BUT is there a way/option to also use the onboard codec and choose in preferences?

Still need Bluetooth
CPU Management

USB ports Still missing 2 on front and the 3.0 ones on the back (al together I have 5 working out of 11 (is there a total fix to use all?)
Attach your PR Files to check further.
 
Thread starter Similar threads Forum Replies Date
EliteMacx86 Catalina Desktop Guide 0
EliteMacx86 Catalina Laptop Guides 0
EliteMacx86 Catalina Laptop Guides 0
EliteMacx86 Catalina Laptop Guides 0
EliteMacx86 Catalina Laptop Guides 0