HP Pavilion G6 1250ej

ShonP40

Member
Joined
Mar 14, 2019
Motherboard
Gigabyte
CPU
Intel Core i5-7600K
Graphics
Nvidia GeForce GTX 1070
OS X/macOS
10.13.6
Bootloader
Clover (UEFI)
Mobile Phone
iOS
Hi, I am trying to install MacOS High Sierra on my HP Pavilion G6 1250ej laptop.

I used UniBeast to create a legacy installation on my USB flash drive (because this laptop doesn't support UEFI) and added the necessary kexts and patches from this GitHub repository.

I booted the installer on the laptop, saw the Apple logo and after a couple of minutes it switched to a grey screen with the mouse curser (I am able to move it). The installer it self and the status bar are not showing up at all.

Is there a fix to it?
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hi, I am trying to install MacOS High Sierra on my HP Pavilion G6 1250ej laptop.

I used UniBeast to create a legacy installation on my USB flash drive (because this laptop doesn't support UEFI) and added the necessary kexts and patches from this GitHub repository.

I booted the installer on the laptop, saw the Apple logo and after a couple of minutes it switched to a grey screen with the mouse curser (I am able to move it). The installer it self and the status bar are not showing up at all.

Is there a fix to it?
No specs provided. Follow the guide here:
 

ShonP40

Member
Joined
Mar 14, 2019
Motherboard
Gigabyte
CPU
Intel Core i5-7600K
Graphics
Nvidia GeForce GTX 1070
OS X/macOS
10.13.6
Bootloader
Clover (UEFI)
Mobile Phone
iOS
1. I used a USB 3.0 32GB flash drive.
2. Here are the specs of the laptop:
Intel ® Core ™ i3-2330M
6 GB RAM
AMD Radeon HD 6470M and Intel HD Graphics 3000 GPU's.

There are no USB 3.0 ports on this laptop.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS
1. I used a USB 3.0 32GB flash drive.
2. Here are the specs of the laptop:
Intel ® Core ™ i3-2330M
6 GB RAM
AMD Radeon HD 6470M and Intel HD Graphics 3000 GPU's.

There are no USB 3.0 ports on this laptop.
Follow the guide i linked above.
 

ShonP40

Member
Joined
Mar 14, 2019
Motherboard
Gigabyte
CPU
Intel Core i5-7600K
Graphics
Nvidia GeForce GTX 1070
OS X/macOS
10.13.6
Bootloader
Clover (UEFI)
Mobile Phone
iOS
Ok, I followed your guide and I am still getting to the same screen.
 

ShonP40

Member
Joined
Mar 14, 2019
Motherboard
Gigabyte
CPU
Intel Core i5-7600K
Graphics
Nvidia GeForce GTX 1070
OS X/macOS
10.13.6
Bootloader
Clover (UEFI)
Mobile Phone
iOS
nvm, I removed the patches that I got from the GitHub repo and it booted up the installer!
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS

ShonP40

Member
Joined
Mar 14, 2019
Motherboard
Gigabyte
CPU
Intel Core i5-7600K
Graphics
Nvidia GeForce GTX 1070
OS X/macOS
10.13.6
Bootloader
Clover (UEFI)
Mobile Phone
iOS
I just noticed that only one of my 3 USB ports is working. Is there any fix to it?
 

ShonP40

Member
Joined
Mar 14, 2019
Motherboard
Gigabyte
CPU
Intel Core i5-7600K
Graphics
Nvidia GeForce GTX 1070
OS X/macOS
10.13.6
Bootloader
Clover (UEFI)
Mobile Phone
iOS
nvm, I solved it by using the patches from the GitHub repository.
 

EliteMacx86

Administrator
Staff member
Joined
Jul 22, 2018
Motherboard
GIGABYTE Z370 AROUS GAMING 3
CPU
Intel Core i9 9900K
Graphics
2xAMD RX 580 8GB
OS X/macOS
10.14.6
Bootloader
Clover (UEFI)
Mac
MacBook Pro
Mobile Phone
Android, iOS